Back to overview
Degraded
Global Intermittent DNS Issues
Aug 15 at 11:09am EDT
Affected services
Web Hosting & Email Services
Resolved
Aug 16 at 10:14am EDT
DNS has been restored to normal functionality.
Affected services
Created
Aug 15 at 11:09am EDT
Event Summary: Global Intermittent DNS Issues
We are currently experiencing intermittent DNS issues in all locations. Our engineers are actively working to resolve the issue as quickly as possible.
Affected services