Back to overview
Degraded
Partial outage in Honolulu and Los Angeles
Mar 30, 2026 at 12:20pm UTC
Affected services
Honolulu - United States
Los Angeles - United States
Resolved
Mar 31, 2026 at 1:13pm UTC
This issue has been resolved
Affected services
Created
Mar 30, 2026 at 12:20pm UTC
We are currently experiencing a partial outage affecting our Honolulu and Los Angeles data centers. Our team is actively working with our upstream provider to identify the root cause and restore full service as quickly as possible.
We understand the impact this may have on your operations and sincerely apologize for the disruption. We will continue to provide updates here as new information becomes available.
Thank you for your patience.
Affected services