Back to overview
Degraded

Singapore Degraded Network Performance

Nov 21 at 07:44am EST
Affected services
Singapore

Resolved
Nov 21 at 10:24am EST

We are seeing resolution and stability in the regions transit provider that was causing issues with network traffic for some of our clients. Our network engineers will continue to monitor the situation for further issues. If you are still experiencing connectivity issues, please let us know.

Created
Nov 21 at 07:44am EST

We are currently experiencing degraded network performance in our Singapore location. Our network engineers are actively working with our upstream providers to resolve the issue as quickly as possible.