Back to overview
Degraded

We are seeing elevated connection issues across our network

Sep 08 at 11:46pm EDT
Affected services
Chicago - United States
Dallas - United States
Los Angeles - United States
Toronto, Canada

Resolved
Sep 09 at 02:46am EDT

This issue is moved to a new status. Global Intermittent DNS Issues.

Created
Sep 08 at 11:46pm EDT

We are monitoring elevated connection issues with certain data centers. We are currently working with our upstream engineers to identify the cause of the issue and we will make further updates to this status.