Back to overview
Degraded

Dallas Network Outage

Jun 17 at 04:33pm EDT
Affected services
Dallas - United States

Resolved
Jun 17 at 05:34pm EDT

The outage to our Dallas location has been resolved.

Created
Jun 17 at 04:33pm EDT

We are currently experiencing a partial outage in our Dallas location. Our network engineers are actively working with our upstream providers to restore connectivity as quickly as possible.