Back to overview
Downtime

We are seeing elevated connection issues across our London network

Jun 09 at 03:31pm EDT
Affected services
London - United Kingdom

Resolved
Jun 09 at 03:50pm EDT

Connectivity in our London Data Center has returned to normal. We are continuing to follow up with our upstream provider and will post a Reason for Outage (RFO) as soon as more information becomes available.

Thank you for your patience and understanding

Updated
Jun 09 at 03:35pm EDT

Connectivity in our London Data Center is returning to normal. We’re continuing to monitor the situation closely alongside our upstream provider to ensure full stability.

We’ll keep this ticket updated with any further developments.

Thank you for your patience

Created
Jun 09 at 03:31pm EDT

Our monitoring has detected elevated connectivity issues in our London Data Center. We are actively working with our upstream provider to assess and troubleshoot the problem.

We will provide an update on this ticket shortly.

Thank you for your patience