Back to overview
Degraded
New Jersey NVMe Block Storage Outage - 2024-10-22
Oct 22 at 02:32pm EDT
Affected services
New York - United States
Resolved
Oct 23 at 02:56pm EDT
This issue has been resolved
Affected services
New York - United States
Created
Oct 22 at 02:32pm EDT
Our Cloud Storage team is investigating an outage with our NVMe Block Storage infrastructure. We are working quickly to restore service to its optimal state.
Affected services
New York - United States