Back to overview
Degraded

Seattle Network Outage

Jun 01 at 11:58am EDT
Affected services
Seattle - United States

Resolved
Jun 02 at 08:29am EDT

The issue was resolved by our upstream provider

Created
Jun 01 at 11:58am EDT

Event Summary: Seattle Network Outage

We are currently experiencing a partial outage in our Seattle location. Our network engineers are actively working with our upstream providers to restore connectivity as quickly as possible.