Back to overview
Downtime

Chicago Datacenter Offline

May 09 at 11:48am EDT
Affected services
Chicago - United States

Resolved
May 11 at 01:45pm EDT

Resolved

Updated
May 09 at 01:07pm EDT

Our engineers in ORD have identified a hardware issue and are working to remove and replace it. We will update this status shortly.

Updated
May 09 at 12:09pm EDT

The current issue with networking is also affecting attached block storage performance. Instances with SNAPS or other attached block stores will exhibit extended wait states on backups and other data transfers.

Our engineers are still working to resolve the issue ASAP.

Created
May 09 at 11:48am EDT

The Chicago datacenter is experiencing network connectivity issues. Our engineers are working on resolving ASAP.