Back to overview
Downtime
Investigating Network Outage in Honolulu
Jul 14 at 07:40am EDT
Affected services
Honolulu - United States
Resolved
Jul 16 at 06:40am EDT
Issue Resolved
Affected services
Honolulu - United States
Created
Jul 14 at 07:40am EDT
We are currently investigating a network outage in our Honolulu data center. Our engineers are working as quickly as possible to resolve this issue and we'll update the status here.
Affected services
Honolulu - United States