Back to overview
Degraded
Chicago Degraded Network Performance
Jul 12 at 12:46pm EDT
Affected services
Chicago - United States
Resolved
Jul 14 at 07:33am EDT
Issue Resolved
Affected services
Chicago - United States
Created
Jul 12 at 12:46pm EDT
We are currently experiencing degraded network performance in our Chicago location. Our network engineers are actively working with our upstream providers to resolve the issue as quickly as possible.
Affected services
Chicago - United States