Back to overview
Downtime
Seattle Partial Outage
Mar 03 at 03:40pm EST
Affected services
Seattle - United States
Resolved
Mar 03 at 04:17pm EST
Our engineers have isolated and resolved the issue. We are currently monitoring for any additional issues.
Affected services
Seattle - United States
Updated
Mar 03 at 03:53pm EST
The issue is ongoing in the Seattle region at this time. Our network engineers are working to resolve this issue as soon as possible.
Affected services
Seattle - United States
Created
Mar 03 at 03:40pm EST
We are currently experiencing a partial outage in our Seattle data center. Our engineers are actively working on this and we will update the status as we have more information.
Affected services
Seattle - United States