Get in touch
Back
Maintenance

London Scheduled Maintenance - 2022-08-02

Completed 2 Aug at 03:00pm EDT.

London - United Kingdom
Completed

Posted 2 Aug at 03:00pm EDT.
Started

Event Summary: London Scheduled Maintenance - 2022-08-02
Event Type: Network Upgrade

We are performing system changes in the London data center during the following scheduled maintenance window.

Start Time: 2022-08-02 15:00:00 UTC
End Time: 2022-08-02 19:00:00 UTC

Posted 2 Aug at 11:00am EDT.