Get in touch
Back
Degraded

London Partial Outage

Started 7 Jul at 03:20am EDT, resolved 8 Jul at 08:30am EDT.

London - United Kingdom
Resolved

All issues are resolved at our London Data Center.

Posted 8 Jul at 08:30am EDT.
Created

We are currently experiencing a partial outage in our London data center. Network Engineers are actively working with our onsite technicians to restore service as quickly as possible.

Posted 7 Jul at 03:20am EDT.