Get in touch
Back
Maintenance

Frankfurt Scheduled Maintenance - 2022-07-11

Completed 11 Jul at 05:00pm EDT.

Frankfurt - Germany
Completed

Posted 11 Jul at 05:00pm EDT.
Started

Event Summary: Frankfurt Scheduled Maintenance - 2022-07-11

Event Type: Network Upgrade

We are performing system changes in the Frankfurt data center during the following scheduled maintenance window.

Posted 11 Jul at 11:00am EDT.